Ilias

Fiber-To-The-Home on OpenWRT
  

Configuring T-Mobile FTTH 1 Gbps network using a Linksys router with OpenWRT


It took me some hours and some help of a friend, but I finally managed to setup a T-Mobile FTTH 1 Gbps network. So today the T-Mobile install tech came by to install the fiber, media-converter, modem/router and ip tv boxes. I asked the guy what VLAN’s T-Mobile is using, he told me that T-Mobile doesn’t use any VLAN’s.. I didn’t trust that answer, so I did some research. I found that T-Mobile is using VLAN 300 for internet and 640 for IPTV, so obviously that answer was incorrect.

I’m using a Linksys wrt 1900ACS with OpenWRT 18.06 (I will not explain how to install OpenWRT, there are many guides on the internet that show you how to install OpenWRT). The steps are actually really simple but it took some time to find that out 😊.

First we need to remove the proprietary T-Mobile Zyxtel router and install the OpenWRT router. Plug the UTP cable directly from the gigabit fiber mediaconverter into to WAN port on the OpenWRT router. SSH into the router and edit some configuration files. I will explain what files I edited and why I made these changes.

We need to change some interfaces. In the OpenWRT documentation you can see some examples, but the examples are focused on DSL connections and there for they use PPPOE in the examples. Many ISP’s are using the PPPOE (point to point protocol over ethernet), PPPOE is a common method of connecting your router to your ISP. To use PPPOE the ISP provides you with a username and password. I never received a username and password so I assumed that they are using DHCP as protocol. The first interface I will be editing is the WAN interface. Here is the configuration of my WAN interface:

config interface ‘wan’
option ifname ‘eth0.300’
option proto ‘dhcp’
option ipv6 ‘auto’
option mtu ‘1508’
option peerdns ‘0’
option dns ‘1.1.1.1’

Remember when I said that T-Mobile Netherlands is using VLAN 300 for internet? In my configuration I assigned VLAN 300 to the WAN interface with the line ‘option ifname ‘eth0.300’, you can also see that I have set the maximum transmission unit (MTU) to 1508 also know as Baby Jumbo Frames and you can see that I am using Cloudflare’s DNS (1.1.1.1).

Now I will add the WAN6 interface. Wan6 is for IPV6. T-Mobile Netherlands doesn’t offer IPV6, but I will configure it any ways (maybe they will offer it in the future). Here is my wan6 interface configuration:

config interface ‘wan6’
option ifname ‘@wan’
option proto ‘dhcpv6’
option reqaddress ‘try’
option reqprefix ‘auto’

Now I will create the IPTV interface. T-Mobile Netherlands uses VLAN 640 for TV so I will assign VLAN 640 to the ‘iptv’ interface. Here is my iptv configuration:

config interface ‘iptv’
option type ‘bridge’
option proto ‘dhcp’
option defaultroute ‘0’
option peerdns ‘0’
option vendorid ‘IPTV_RG’
option ifname ‘eth0.640’

So now we need to create a firewall zone for the IPTV interface in /etc/config/firewall. We need to NAT the traffic for this interface. Here is the configuration for the IPTV zone:

config zone
option name ‘iptv’
option input ‘ACCEPT’
option output ‘ACCEPT’
option network ‘iptv’
option masq ‘1’
option mtu_fix ‘1’
option forward ‘reject’

Now we have created interfaces and a firewall zone. The only thing we need to do is configuring the switch. You need to ‘untagg’ VLAN 640 on the port on which your tv-box is connected. And you need to tagg VLAN 1 on the ports you want to use regular internet on (VLAN 1 = LAN).

Speedtest is giving me 900+/- Mbps up and down. And the TV is working perfectly. I call this a successful installation. Special thanks to my Canadian friend that helped me, you know who you are and to the guys that wrote the OpenWRT docs.

Ps: Dear T-Mobile it’s 2020 please start offering ipv6.


Reply via Email →